登录
  • 欢迎访问老王的博客,本站用来做博主的技术学习,工作记录,技术分享,互动交流!
  • 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏老王的博客吧

将centos7自带的php5.4升级为5.6并安装扩展

linux wmhbcy 1297次浏览 0个评论 扫描二维码

老王经常在装完LAMP一键安装包装完环境后,因为PHP版本原因,经常有各种各样的问题,因为LAMP环境包很多软件版本是固定的,所以不得不升级PHP或者添加一些扩展

  1. 1.进入终端后查看php版本
  2. php -v
  3. 输出可能如下:
  4. PHP 5.4.35 (cli) (built: Nov 14 2014 07:04:10) Copyright (c) 1997-2014 The PHP Group Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies    with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2015, by Zend Technologies
  1. 2.执行下面的命令升级软件仓库
  2.  rpm -Uvh https://mirror.webtatic.com/yum/el7/epel-release.rpm
  3.  rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm
  1. 3.执行下面的命令删除php
  2. yum remove php-common
  3. 然后像安装那样问你是否继续的,输入yes即可
  • 4.安装php 5.6版本(php56w-devel这个不是必需的)
  • 5.这条命令可以方便的安装各种PHP扩展, yum install -y是固定的,php56w是当前安装的php版本,只要版本写对了,后面的扩展可以随意安装,非常方便。
  • yum install -y php56w php56w-opcache php56w-xml php56w-mcrypt php56w-gd php56w-devel php56w-mysql php56w-intl php56w-mbstring  php56w-openssl php56w-Tokenizer php56w-posix php56w-pcntl

 

老王常用的2个框架需要的PHP扩展:

  • Laravel框架有少量的系统要求:
    • PHP版本 >= 5.5.9
    • PHP扩展:OpenSSL
    • PHP扩展:PDO
    • PHP扩展:Mbstring
    • PHP扩展:Tokenizer
  • Workerman通讯框架
  • 1、安装PHP>=5.3.3,并安装了pcntl、posix扩展
  • 2、建议安装event或者libevent扩展,但不是必须的(注意event扩展需要PHP>=5.4)
  1. 5.重启httpd
  2. service httpd restart
  3. 查看最新的版本
  4. php -v
  5. 现在应该是5.6了!

老王的博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明出处!
喜欢 (0)
[23419610@qq.com]
分享 (0)
关于作者:
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到